Conteggio Excel

Excel, quante volte un valore compare in un elenco?

Spesso utilizzando Excel abbiamo la necessità di evidenziare oppure eliminare le righe duplicate di una tabella, ci sono molte funzioni e molti strumenti che ci aiutano in queste operazioni, oggi vedremo come calcolare quante volte un valore compare in un elenco.

Se desideriamo sapere quante volte viene duplicato un valore in un elenco Excel, per prima cosa,dobbiamo creare un elenco di valori univoci presenti nella colonna da analizzare.

Per questa operazione potrebbe interessarti leggere l’articolo Eliminare valori duplicati in una colonna.

Premessa

A titolo esemplificativo consideriamo che la colonna A (A1:A100) contenga un elenco di valori con alcuni valori duplicati.

Risultato

Vogliamo riportare nella colonna D un elenco di valori univoci estratta dalla colonna A e nella colonna E il numero di apparizioni dei valori della colonna D nella colonna A

Procedura Excel – contare quante volte un valore compare in un elenco

Per fare questa operazione utilizzeremo la funzione conta.se questa funzione è una delle funzioni statistiche, utilizzata per contare il numero di celle che soddisfano un determinato criterio.

La sintassi della funzione è =CONTA.SE(Intervallo; Criterio) quindi  CONTA.SE (Dove si vuole cercare?; Cosa si vuole cercare?)

  1. Selezionare la cella E2 (supponiamo che nella cella D2 compaia il primo dei valori univoci da cercare mentre le celle E1 e D1 contengano le intestazioni di colonna)
  2. Inserire la funzione Conta.se con la seguente sintassi: =conta.se(A:A;D2) (versione 1)  oppure  =conta.se($A$1:$A$100;D2) (versione 2)
  3. Nella cella E2 apparirà il conteggio e sapremo quante volte il valore presente in D2 compare nella colonna A

Differenze tra la versione 1 o la versione 2

La formula =conta.se(A:A;D2) sarà funzionante anche se si aggiungono valori oltre la riga 100 se invece non vogliamo contare i valori oltre la riga 100 utilizzeremo la formula  =conta.se($A$1:$A$100;D2)

La formula inserita deve essere copiata sulle righe successive, ad esempio utilizzando il quadratino di riempimento.

A tale scopo il parametro intervallo viene inserito come riferimento assoluto $A$1:$A$100 mentre il parametro Criterio viene inserito come riferimento relativo, nella prima versione della formula che fa riferimento a tutta la colonna A non è necessario utilizzare i riferimenti assoluti.

Potrebbe interessarti l’articolo:

Evidenziare i valori duplicati di una colonna

Formula Excel per contare quanti duplicati di un valore appaiono in una colonna

Formula Excel per inserire un “ordine di apparizione” di un valore in una colonna

Posted in Excel and tagged .